ALTQ(4) Kernel Interfaces Manual ALTQ(4)
altq -- alternate queuing framework
The altq framework provides several disciplines for queuing outgoing
network packets. While traffic shaping is perhaps the most prominent
example, altq provides also other measures related to QoS. The framework
has been integrated to the pf(4) packet filter since NetBSD 4.0.
At the implementation level altq modifies the interface packet queues.
Therefore the driver modifications described in altq(9) are required in
order to use a certain network card with altq.
pf(4), altq.conf(5), altqd(8), altq(9)
Kenjiro Cho, Fitting theory into reality in the ALTQ case, March, 2004,
Asia BSD conference, Taipei, Taiwan,
NetBSD 6.1.5 June 22, 2011 NetBSD 6.1.5