AKBD(4) Kernel Interfaces Manual AKBD(4)
akbd -- Apple Desktop Bus keyboard driver for wscons
akbd* at obio?
wskbd* at akbd? console ?
This driver provides the wscons(4) driver with support for Apple Desktop
To work around the limited number of buttons found on most ADB mice, one
can map key sequences to trigger mouse button events. To map Option+1,
Option+2, Option+3 to mouse buttons 1, 2, and 3 respectively, add the
following line to your kernel configuration file:
On macppc systems it is possible to tweak the keyboard driver to treat
the caps lock key on an ADB keyboard as a control key. This requires
special remapping because of ADB's strange emulation of a mechanically-
locked key. To enable this code add the following line to your kernel
On macppc PowerBooks, several function keys double as "hot keys"
(brightness, volume, eject) when the Fn modifier is held down. Mac OS X
likes to reprogram the keyboard controller to send hot key events when Fn
is not held down and send function key events when it is. To transform
the non-keyboard "button" events back into function key events, place the
following line in your kernel configuration file:
NetBSD is known to support the following ADB keyboards:
o On-board keyboards on PowerBook models
o Apple Standard Keyboard
o Apple Keyboard II
o Apple Extended Keyboard
o Apple Extended Keyboard II
o Apple Adjustable Keyboard
o Most third-party ADB keyboards are supported
adb(4), wscons(4), wskbd(4), wsconsctl(8)
The number pad on extended keyboards does not send out the proper key
codes for many applications.
The LEDs on extended keyboards are not functional under NetBSD.
NetBSD 6.1.5 September 21, 2003 NetBSD 6.1.5