AIBS(4) BSD Kernel Interfaces Manual AIBS(4)
aibs -- ASUSTeK AI Booster ACPI ATK0110 temperature, voltage, and fan
aibs* at acpi?
The aibs driver provides support for the voltage, temperature and fan
sensors available through the ATK0110 ACPI device on ASUSTeK mother-
boards. The number of sensors of each type, as well as the description
of each sensor, varies according to the motherboard.
The driver supports an arbitrary set of sensors, provides a description
regarding what each sensor is used for, and reports whether each sensor
is within the specifications as defined by the motherboard manufacturer
The aibs driver supports sensor states as follows: temperature sensors
can have a state of OK, WARN, CRIT or UNKNOWN; fan and voltage sensors
can have a state of OK or WARN only. Temperature sensors that have a
reading of 0 are marked as invalid and their state is set to UNKNOWN,
whereas all other sensors are always assumed valid. Temperature sensors
have two upper limits (WARN and CRIT), fan sensors have either only the
lower limit, or one lower and one upper limit, and voltage sensors always
have a lower and an upper limit.
Sensor values are made available through the HW_SENSORS sysctl(3) inter-
face, and can be monitored with the systat(1) sensors view, sensorsd(8),
or sysctl(8) hw.sensors. For example, on an Asus Stricker Extreme moth-
$ sysctl hw.sensors.aibs0
hw.sensors.aibs0.temp0=31.00 degC (CPU Temperature), OK
hw.sensors.aibs0.temp1=43.00 degC (MB Temperature), OK
hw.sensors.aibs0.fan0=2490 RPM (CPU FAN Speed), OK
hw.sensors.aibs0.fan1=0 RPM (CHASSIS FAN Speed), WARNING
hw.sensors.aibs0.fan2=0 RPM (OPT1 FAN Speed), WARNING
hw.sensors.aibs0.fan3=0 RPM (OPT2 FAN Speed), WARNING
hw.sensors.aibs0.fan4=0 RPM (OPT3 FAN Speed), WARNING
hw.sensors.aibs0.fan5=0 RPM (OPT4 FAN Speed), WARNING
hw.sensors.aibs0.fan6=0 RPM (OPT5 FAN Speed), WARNING
hw.sensors.aibs0.fan7=0 RPM (PWR FAN Speed), WARNING
hw.sensors.aibs0.volt0=1.26 VDC (Vcore Voltage), OK
hw.sensors.aibs0.volt1=3.25 VDC ( +3.3 Voltage), OK
hw.sensors.aibs0.volt2=4.95 VDC ( +5.0 Voltage), OK
hw.sensors.aibs0.volt3=11.78 VDC (+12.0 Voltage), OK
hw.sensors.aibs0.volt4=1.23 VDC (1.2VHT Voltage), OK
hw.sensors.aibs0.volt5=1.50 VDC (SB CORE Voltage), OK
hw.sensors.aibs0.volt6=1.25 VDC (CPU VTT Voltage), OK
hw.sensors.aibs0.volt7=0.93 VDC (DDR2 TERM Voltage), OK
hw.sensors.aibs0.volt8=1.23 VDC (NB CORE Voltage), OK
hw.sensors.aibs0.volt9=1.87 VDC (MEMORY Voltage), OK
Generally, sensors provided by the aibs driver may also be supported by a
variety of other drivers, such as lm(4) or it(4). The precise collection
of aibs sensors is comprised of the sensors specifically utilised in the
motherboard design, which may be supported through a combination of one
or more physical hardware monitoring chips.
The aibs driver, however, provides the following advantages when compared
to the native hardware monitoring drivers:
o Sensor values from aibs are expected to be more reliable. For exam-
ple, voltage sensors in many hardware monitoring chips can only sense
voltage from 0 to 2 or 4 volts, and the excessive voltage is removed
by the resistors, which may vary with the motherboard and with the
voltage that is being sensed. In aibs, the required resistor factors
are provided by the motherboard manufacturer through ACPI; in the
native drivers, the resistor factors are encoded into the driver
based on the chip manufacturer's recommendations. In essence, sensor
values from aibs are very likely to be identical to the readings from
the Hardware Monitor screen in the BIOS.
o Sensor descriptions from aibs are more likely to match the markings
on the motherboard.
o Sensor status is supported by aibs. The status is reported based on
the acceptable range of values for each individual sensor as sug-
gested by the motherboard manufacturer. For example, the threshold
for the CPU temperature sensor is likely to be significantly higher
than that for the chassis temperature sensor.
o Support for newer chips in aibs. Newer chips may miss a native
driver, but should be supported through aibs regardless.
As a result, sensor readings from the actual native hardware monitoring
drivers may be ignored as appropriate.
systat(1), sysctl(3), acpi(4), intro(4), sensorsd(8), sysctl(8)
The aibs driver first appeared in OpenBSD 4.7.
The aibs driver was written by Constantine A. Murenin <firstname.lastname@example.org>,
University of Waterloo.
BSD August 14, 2013 BSD