ADDCOM(4) BSD Kernel Interfaces Manual ADDCOM(4)
addcom -- multiplexing serial communications interface
addcom0 at isa? port 0x108 irq 5
com* at addcom?
The addcom driver provides support for Addonics FlexPort 8/S (and proba-
bly FlexPort 4/S) boards that multiplex together up to eight (or four)
EIA RS-232C (CCITT V.28) communications interfaces.
Each addcom device is the master device for up to eight com devices. The
kernel configuration specifies these com devices as slave devices of the
addcom device, as shown in SYNOPSIS. The slave ID given for each com
device determines which bit in the interrupt multiplexing register is
tested to find interrupts for that device. The port specification for
the addcom device is used to compute the base addresses for the com sub-
devices. The port for the interrupt multiplexing register is fixed, so
it is doubtful that more than one addcom can be used in a machine.
com(4), intro(4), isa(4)
OpenBSD support for addcom devices first appeared in OpenBSD 3.0.
BSD May 30, 2017 BSD