ACPIWMI(4) Kernel Interfaces Manual ACPIWMI(4)
acpiwmi -- Windows Management Instrumentation support for ACPI
acpiwmi* at acpi?
acpiwmibus* at acpiwmi?
wmidell* at acpiwmibus?
wmieeepc* at acpiwmibus?
wmihp* at acpiwmibus?
wmimsi* at acpiwmibus?
The acpiwmi device driver provides an ACPI interface for Windows
Management Instrumentation (WMI). The ACPI WMI interface is typically
used to support vendor specific features found in various laptops.
The following WMI mappings are supported:
wmidell Dell laptops
wmieeepc Some models of Asus Eee PC
wmihp Hewlett-Packard laptops
wmimsi MSI laptops
The functionality varies from vendor to vendor. Typically the interface
is used for function and hotkey handling, but additional features may be
Microsoft Corporation, Windows Instrumentation: WMI and ACPI, December 4,
The acpiwmi device driver appeared in NetBSD 6.0.
Jukka Ruohonen <jruohonenATiki.fi> wrote acpiwmi and most of the mappings.
While WMI should provide a certain degree of portability across laptop
models from a particular vendor, there is no guarantee that the mappings
are functional in all models.
The wmihp driver may conflict with hpqlb(4).
NetBSD 6.1.5 February 16, 2011 NetBSD 6.1.5