ACPI_THERMAL(4) BSD Kernel Interfaces Manual ACPI_THERMAL(4)
acpi_thermal -- ACPI thermal management subsystem
The acpi_thermal driver provides the thermal management features of the
ACPI module. This driver has a sysctl(8) interface and a devd(8) notifi-
cation interface. The sysctls export properties of each ACPI thermal
There can be multiple thermal zones in a system. For example, each CPU
and the enclosure could all be separate thermal zones, each with its own
setpoints and cooling devices. Thermal zones are numbered sequentially
in the order they appear in the AML.
The acpi_thermal driver also activates the active cooling system accord-
ing to each thermal zone's setpoints.
Current active cooling system state. If this is non-negative,
the appropriate _AC%d object is running. Set this value to the
desired active cooling level to force the corresponding fan
object to the appropriate level.
Current thermal zone status. These are bit-masked values.
Current temperature for this zone.
Temperature to start passive cooling by throttling down CPU, etc.
Temperature to start critical suspend to disk (S4).
Temperature to start critical shutdown (S5).
Temperatures at which to switch to the corresponding active cool-
ing level. For instance, values of "3200 3100" mean to switch on
_AC0 at 320.0K and _AC1 at 310.0K. The lower the _ACx value, the
higher the cooling power.
All temperatures are represented in tenths of a Kelvin. For example,
300.0K is represented by the integer 3000. To convert to units of Centi-
grade, the formula is (x - 2731.5) / 10.
Notifies are passed to userland via devd(8). See /etc/devd.conf and
devd.conf(5) for examples. The acpi_thermal driver sends events with the
type The fully qualified thermal zone object path as in the ASL.
notify An integer designating the event:
0x80 Current temperature has changed.
0x81 One or more trip points (_ACx, _PSV) have changed.
0x82 One or more device lists (_ALx, _PSL, _TZD) have
0xcc Non-standard notify that the system will shutdown if
the temperature stays above _CRT or _HOT for one more
This manual page was written by Takanori Watanabe.
BSD December 27, 2003 BSD