volcopy, labelit - copy a file system with label checking
/usr/sbin/volcopy [options] fsname special1 volname1 special2
/usr/sbin/labelit [options] special [fsname volume [-n]]
The volcopy command makes a literal copy of the file system using a
block size matched to the device.
volcopy recognizes the following options:
-F FStype Specify the file system type on which to operate
(see fstyp(1M) and fs_wrapper(5)). If this option
is not included on the command line, then the file
system type is determined from the file /etc/fstab
by matching special with an entry in that file.
If there is no entry in /etc/fstab, then the file
system type is determined from the file
-a Invoke a verification sequence requiring a
positive operator response instead of the standard
delay before the copy is made.
Specify options specific to the file system type.
specific_options is a list of suboptions and/or
keyword/attribute pairs intended for an FStype-
specific module of the command. See the file
system specific manual entries for a description
of the specific_options that are supported, if
-s (default) Invoke the DEL-if-wrong verification
-y Assume a yes response to all questions
-V Echo the completed command line, but perform no
other actions. The command line is generated by
incorporating the user-specified options and
arguments with other information derived from
/etc/fstab. This option allows the user to verify
the command line.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
Other options are used with 9-track magnetic tapes:
-bpi density Bits per inch.
-feet size Size of reel in feet.
-reel num Beginning reel number for a restarted copy.
-buf Use double buffered I/O.
The volcopy command requests length and density information if they
are not given on the command line and they are not recorded on an
input tape label. If the file system is too large to fit on one reel,
the volcopy command prompts for additional reels. Labels of all reels
are checked. Tapes can be mounted alternately on two or more drives.
If the volcopy command is interrupted, it asks if the user wants to
quit or wants to escape to the command interpreter. In the latter
case, other operations (such as executing the labelit command) can be
performed before returning to the volcopy command by exiting the
fsname The file system name on the device (e.g., root) being
special The physical disk section or tape (e.g., /dev/rdsk/1s3 or
volname The physical volume name; it should match the external
sticker. Such label names are limited to six or fewer
characters. The argument volname can be - to use the
existing volume name.
special1 The device from which the copy of the file system is being
volname1 The volume from which the copy of the file system is being
special2 The target device.
volname2 The target volume.
The labelit command can be used to provide initial labels for
unmounted disk or tape file systems. With the optional arguments
omitted, the labelit command prints current label values. The -n
option provides for initial labeling of new tapes only (this destroys
previous contents). The -F, -V, and -o options can be specified for
the labelit command. The behavior of the -F, -V, and -o options is
similar to their behavior in the volcopy command.
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
/etc/default/fs File that specifies the default file system
/etc/fstab Static information about the file systems.
volcopy_hfs(1M), volcopy_vxfs(1M), fs_wrapper(5).
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000