uucpd - UUCP over TCP/IP server daemon
uucpd is the server for supporting UUCP connections over TCP/IP
uucpd is invoked by inetd(1M) when a UUCP connection is established
(that is, a connection to the port indicated in the "uucp" service
specification; see services(4)), and executes the following protocol:
1) The server prompts with "login:", the uucico process at the
other end must supply a username.
2) Unless the username refers to an account without a password,
the server then prompts with "Password:", the uucico process
at the other end must supply the password for that account.
If the username is not valid or is valid but refers to an account that
does not have /usr/lbin/uucp/uucico as its login shell, or if the
password is not the correct password for that account, the connection
is dropped. Otherwise, uucico(1M) is run. Entries are made in
/var/adm/wtmp traceable with who(1) and last(1).
Only 'g' protocol for uucico is supported.
All diagnostic messages are returned on the connection, after which
the connection is closed.
An error occurred while reading the username.
An error occurred while reading the password.
The username or the password is invalid or the user's login shell
for this account is not /usr/lbin/uucp/uucico.
On Trusted Systems uucpd prohibits uucico to start if any of the
following are true :
+ the login account is locked (several causes).
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
+ current time doesn't match existing time-of-day restrictions
for this account.
Under such conditions uucpd will return the message login incorrect to
the connection. The connection is then dropped.
uucpd was developed by the University of California, Berkeley and HP.
/etc/inetd.conf configuration file for inetd
/var/adm/inetd.sec optional security file for inetd
/etc/services service name data base
/var/adm/wtmp login data base
inetd(1M), services(4), uucico(1M).
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000