udpublickey - update the publickey database file and the NIS map
The Network Information Service (NIS) was formerly known as Yellow
Pages (yp). Although the name has changed, the functionality of the
service remains the same.
udpublickey is executed from the updaters(1M) makefile when either
newkey or rpc.ypupdated updates the /etc/publickey database file.
udpublickey receives the following information from newkey or
Requestor's name (a string)
Type of update
Number of bytes in key
Number of bytes in data
After receiving this information, udpublickey attempts to update the
publickey database file, /etc/publickey.
If the update is successful, udpublickey makes the NIS map,
If the update is completely successful, udpublickey exits with a zero
(0) status; otherwise udpublickey exits with a valid NIS error.
This command should not be run interactively.
udpublickey was developed by Sun Microsystems, Inc.
newkey(1M), rpc.ypupdated(1M), updaters(1M), publickey(4).
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000