strerr - receive error messages from the STREAMS log driver
strerr [-a sys_admin_mail_name] [-d logdir]
The strerr daemon receives error messages from the STREAMS log driver
(strlog(7)) for addition to the STREAMS error log files (error.mm-dd)
in the STREAMS error logger directory (/var/adm/streams by default).
When first called, strerr creates the log file error.mm-dd. This is a
daily log file, where mm indicates the month and dd indicates the day
of the logged messages. strerr then appends error messages to the log
file as they are received from the STREAMS log driver.
STREAMS error log messages have the following format:
seq time tick pri ind mod sub text
Components are interpreted as follows:
seq Error event sequence number.
time Time the message was sent expressed in hh:mm:ss.
tick Time the message was sent expressed in machine ticks since
the last boot.
pri Error priority level as defined by the STREAMS driver or
module that originates the messages.
ind Can be any combination of the following three message
T The message has also been saved in the trace log.
F The message signaled a fatal error.
N The message has also been mailed to the system
mod Module identification number of the error message source.
sub Subidentification number of the error message source.
text Error message text.
strerr runs continuously until terminated by the user.
strerr recognizes the following options and command-line arguments:
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
-a sys_admin_mail_name Specify the user's mail name for sending
mail messages. Mail is sent to the
system administrator by default.
-d logdir Specify the directory to contain the
error log file. Default is
Only one strerr process can open the STREAMS log driver at a time.
This restriction is intended to maximize performance.
The STREAMS error logging mechanism works best when it is not
overused. strerr can degrade STREAMS performance by affecting the
response, throughput, and other behaviors of the drivers and modules
that invoke it. strerr also fails to capture messages if drivers and
modules generate messages at a higher rate than its optimum read rate.
If there are missing sequence numbers among the messages in a log
file, messages have been lost.
/usr/lib/nls/msg/C/strerr.cat NLS catalog for strerr.
/var/adm/streams/error.mm-dd error log file or files
on which strerr operates
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000