strace - write STREAMS event trace messages to standard output
strace [ mod sub pri ] ...
strace gets STREAMS event trace messages from STREAMS drivers and
modules via the STREAMS log driver (strlog(7)), and writes these
messages to standard output. By default, strace without arguments
writes all STREAMS trace messages from all drivers and modules.
strace with command-line arguments limits the trace messages received.
The arguments, which must be specified in groups of three, are:
mod Specifies the STREAMS module identification number from the
sub Specifies a subidentification number (often corresponding to
a minor device).
pri Specifies a tracing priority level. strace gets messages of
a level equal to or less than the value specified by pri.
Only positive integer values are allowed.
The value all can be used for any argument in the strace command line
to indicate that there are no restrictions for that argument.
Multiple sets of the three arguments can be specified to obtain the
messages from more than one driver or module.
Only one strace process can open the STREAMS log driver at a time.
When strace is invoked, the log driver compares the sets of command
line arguments with actual trace messages, returning only messages
that satisfy the specified criteria.
STREAMS event trace messages have the following format:
seq time tick pri ind mod sub text
Components are interpreted as follows:
seq Trace event sequence number.
time Time the message was sent expressed in hh:mm:ss.
tick Time the message was sent expressed in machine ticks since
the last boot.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
pri Tracing priority level as defined by the STREAMS driver or
module that originates the messages.
ind Can be any combination of the following three message
E The message has also been saved in the error log.
F The message signaled a fatal error.
N The message has also been mailed to the system
mod Module identification number of the trace message source.
sub Subidentification number of the trace message source.
text Trace message text.
strace runs until terminated by the user.
Display all trace messages received from the driver or module
identified by mod 28:
strace 28 all all
Display trace messages of any tracing priority level from the driver
or module identified by mod 28 and its minor devices identified by the
sub 2, 3, or 4:
strace 28 2 all 28 3 all 28 4 all
Display the trace messages from the same driver or module and subs but
limit the priority levels to 0 for subs 2 and 3; 1 for sub 4, driver
or module 28:
strace 28 2 0 28 3 0 28 4 1
Running strace with several sets of arguments can impair STREAMS
performance, particularly for those modules and drivers that are
sending the messages.
Also be aware that strace may not be able to handle a large number of
messages. If drivers and modules return messages to strace too
quickly, some may be lost.
/usr/lib/nls/msg/C/strace.cat NLS catalog for
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
strclean(1M), strerr(1M), strlog(7).
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000