sprayd - spray server
/usr/lib/netsvc/spray/rpc.sprayd [-l log_file] [-e|-n]
sprayd is an RPC server that records the packets sent by spray from
another system (see spray(1M)).
inetd invokes sprayd through /etc/inetd.conf (see inetd(1M)).
sprayd recognizes the following options and command-line arguments:
-l log_file Log any errors to the named log file, log_file.
Errors are not logged if the -l option is not
Information logged to the file includes date and
time of the error, host name, process id and name
of the function generating the error, and the
error message. Note that different services can
share a single log file since enough information
is included to uniquely identify each error.
-e Exit after serving each RPC request. Using the -e
option, the inetd security file /var/adm/inetd.sec
can control access to RPC services.
-n Exit only if
+ portmap dies (see portmap(1M)),
+ Another rpc.sprayd registers with portmap,
+ rpc.sprayd becomes unregistered with
The -n option is more efficient because a new process is not launched
for each RPC request. -n is the default.
sprayd was developed by Sun Microsystems, Inc.
inetd(1M), spray(1M), portmap(1M), inetd.conf(4), inetd.sec(4),
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000