remove mapping(1m) OSF remove mapping(1m)
remove mapping - Removes specified elements from the local endpoint
rpccp remove mapping -b string-binding -i interface-identifier [-o
-b Specifies a string representation of a binding over which
the server can receive remote procedure calls. At least one
binding is required.
The value has the form of an RPC string binding, without an
object UUID, for example:
Note that depending on your system, string binding
delimiters such as brackets ([ ]) may need to be preceded by
an escape symbol (\) or placed within quotation marks (' '
or `` ''). Requirements vary from system to system, and you
must conform to the usage rules of a system.
-i Specifies an interface identifier to remove from the local
endpoint map. An interface identifier is required. Only one
interface can be removed in a single operation. The
interface identifier has the following form:
The UUID is a hexadecimal string and the version numbers are
decimal strings, for example:
Leading zeros in version numbers are ignored.
-o Defines an object UUID that further determines the endpoint
map elements that are removed (optional). Each remove
mapping command accepts up to 32 -o options.
The UUID is a hexadecimal string, for example:
The remove mapping command removes server address information from the
local endpoint map. Each element in the local endpoint map logically
Hewlett-Packard Company - 1 - OSF DCE 1.1/HP DCE 1.8
remove mapping(1m) Open Software Foundation remove mapping(1m)
contains the following:
+ Interface ID, consisting of an interface UUID and versions (major
+ Binding information
+ Object UUID (optional)
+ Annotation (optional)
This command requires one interface identifier (the -i option); at
least one string binding (the -b option); and optionally, one or more
object UUIDs (the -o option). Each instance of the command accepts
from 1 to 32 -b options and from 0 to 32 -o options. The options work
together to delimit the elements to be removed from the target
endpoint map. The command removes any map element that contains the
specified interface identifier, a specified string binding, and a
specified object UUID (if any).
This command is replaced at Revision 1.1 by the dcecp command and may
not be provided in future releases of DCE.
The following command operates from the system prompt to remove a map
element from the local endpoint map. The command removes only the map
element that contains the specified interface identifier, server
address (specified as a string binding), and object UUID.
rpccp remove mapping \
-i ec1eeb60-5943-11c9-a309-08002b102989,1.1 \
-b ncadg_ip_udp:220.127.116.11 \
Commands: add mapping(1m), show mapping(1m), show server(1m)
Hewlett-Packard Company - 2 - OSF DCE 1.1/HP DCE 1.8