rlpdaemon - remote spooling line printer daemon, message write daemon
/usr/sbin/rlpdaemon [-i] [-l] [-L logfile]
rlpdaemon is a line printer daemon (spool area handler) for remote
spool requests. rlpdaemon is normally invoked at boot time from the
/sbin/rc file or started by inetd(1M), when necessary. rlpdaemon runs
on a system that receives requests to be printed. rlpdaemon transfers
files to the spooling area, displays the queue, or removes jobs from
rlpdaemon is also used as a server process to write a message on the
user's terminal, upon receiving a request from a remote system.
-i Prevent rlpdaemon from remaining after a request is
processed. This is required if rlpdaemon is started from
-l Cause rlpdaemon to log error messages and valid requests
received from the network to the file /var/adm/lp/lpd.log.
This can be useful for debugging.
-L logfile Change the file used for writing error conditions from the
file /var/adm/lp/lpd.log to logfile.
When rlpdaemon is started by inetd(1M), access control is provided via
the file /var/adm/inetd.sec to allow or prevent a host from making
requests. When rlpdaemon is not started by inetd(1M), all requests
must come from one of the machines listed in the file /etc/hosts.equiv
or /var/spool/lp/.rhosts. When /var/spool/lp/.rhosts is used for
access, the user name should be lp.
The following entry should exist in /etc/services for remote spooling:
printer 515/tcp spooler
To start rlpdaemon from /sbin/rc, invoke the command:
To start rlpdaemon from inetd, the following line should be included
in the file /etc/inetd.conf:
printer stream tcp nowait root /usr/sbin/rlpdaemon rlpdaemon -i
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
If the remote system is the same as the local system and rlpdaemon was
not started by inetd(1M), the local system name must be included in
rlpdaemon was developed by the University of California, Berkeley and
accept(1M), enable(1), lp(1), inetd(1M), lpadmin(1M), lpsched(1M),
lpstat(1), rcancel(1M), rlp(1M), rlpdaemon(1M), rlpstat(1M).
hosts.equiv(4), inetd.conf(4), inetd.sec(4), services(4).
HP-UX System Administrator manuals
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000