remove object(1m) OSF remove object(1m)
remove object - Removes a value from a set-valued or single-valued
attribute (including application-defined attributes) of an object
cdscp remove object object-name attribute-name [= attribute-value]
The full name of the object entry.
The name of a particular attribute. Specify only one
attribute at a time. See the cds_attributes file for the
list of attributes and corresponding data types that your
The value of a particular attribute. The value of an
application-defined attribute is dependent on the type of
The remove object command removes a value from a set-valued or
single-valued attribute (including application-defined attributes) of
an object entry. If you do not specify a value, the command removes
the entire attribute. This command can delete attributes created by
the add object and set object commands. Usually, this task is
performed through the client application. See the OSF DCE
Administration Guide for more information about attributes.
You must have write permission to the object entry.
This command is replaced at Revision 1.1 by the dcecp command and may
not be provided in future releases of DCE.
To remove the value ps from the attribute printcap of an object entry
named /.:/mlh/deskprinter, follow these steps:
1. Read the cds_attributes file to check that the attribute printcap
is listed, as shown in the following display:
OID LABEL SYNTAX
184.108.40.206.3.50 printcap char
Hewlett-Packard Company - 1 - OSF DCE 1.1/HP DCE 1.8
remove object(1m) Open Software Foundation remove object(1m)
2. Enter the following command to remove the value ps from the
dscp>>>> remove object /.:/mlh/deskprinter printcap = ps
Commands: add object(1m), list object(1m), set object(1m), show
Books: OSF DCE Administration Guide
Hewlett-Packard Company - 2 - OSF DCE 1.1/HP DCE 1.8