recserv - HP SharedX Receiver Service
HP SharedX Receiver Service provides a method for a receiver to allow
the sharing of windows without explicitly performing any xhost
commands. The Internet daemon (inetd(1M)) executes recserv when it
receives a service request at the port listed in the services data
base for recserv (see inetd(1m) and services(4)).
When recserv is executed via inetd, a dialog box appears informing the
receiver of the share request by the sender. The receiver can allow
or disallow the share request by selecting the YES or NO button.
recserv allows sharing by xhosting the sender just long enough for it
to make a connection to the receiver. Once the connection is
established recserv removes the sender from the access control list,
unless the sender was entered in the list prior to the execution of
recserv. Since no permanent change is made to the access control list,
security is maintained at its highest level.
To start recserv from the Internet daemon, the configuration file
/etc/inetd.conf must include the single line entry,
recserv stream tcp nowait bin /usr/lbin/recserv recserv -display :0
and the services file /etc/services must include the line,
recserv 7815/tcp # SharedX Receiver Service
Receiver Service options, set by selecting the Options button, dictate
the behavior of recserv. The behavior can also be set by running
recserv manually. In either case, an X server resource is set
dictating the behavior for subsequent invocations of recserv.
The following options allow different behavior according to user
The dialog will pop up each time sharing is requested,
regardless of the security on your X server.
The dialog box never appears, but sharing will always be
Hewlett-Packard Company - 1 - HP-UX 10.0 July 1994
The dialog will pop up only if the sender's machine is not
hosted on your machine. If the sender's machine is already
hosted, sharing will occur without a dialog appearing.
The dialog will never appear. Windows are shared only if
the sender's machine is already hosted by your server.
To set resources (system behavior, label strings, etc) globally for a
system, edit the file /usr/lib/X11/app-defaults/RecServ.
HP SharedX Receiver Service was developed by Hewlett Packard.
SharedX(1), inetd(1M), xhost(1), hosts(4), inetd.conf(4),
Hewlett-Packard Company - 2 - HP-UX 10.0 July 1994