quotaon, quotaoff - turn HFS file system quotas on and off
/usr/sbin/quotaon [-v] filesystem ...
/usr/sbin/quotaon [-v] -a
/usr/sbin/quotaoff [-v] filesystem ...
/usr/sbin/quotaoff [-v] -a
These commands are provided for compatibility only. Their use is
neither required nor recommended because mount and umount enable and
disable quotas cleanly (see mount(1M)). See WARNINGS below for more
The quotaon command enables quotas on one or more HFS file systems.
The quotaoff command disables quotas on one or more HFS file systems.
filesystem is either the name of the mount point of the file system,
or the name of the block device containing the file system. The file
systems specified must be currently mounted in order to turn quotas on
or off. Also, the file system quota file, quotas, must be present in
the root directory of each specified file system.
These commands will update the appropriate entries in /etc/mnttab to
indicate that quotas are on or off for each file system.
When enabling quotas interactively after boot time, the quotacheck
command should be run immediately afterward (see WARNINGS below).
Use mount (see mount(1M)) to determine whether quotas are enabled on
mounted file systems.
The following options affect the behavior described above.
-a Obtain the filesystem list from /etc/fstab, using entries of
type hfs and rw (or default) with the quota option (see
-v Generate a message for each file system affected.
LC_MESSAGES determines the language in which messages are displayed.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
If LC_MESSAGES is not specified in the environment or is set to the
empty string, the value of LANG is used as a default for each
unspecified or empty variable. If LANG is not specified or is set to
the empty string, a default of "C" (see lang(5)) is used instead of
If any internationalization variable contains an invalid setting,
quotaon behaves as if all internationalization variables are set to
"C". See environ(5).
International Code Set Support
Single- and multi-byte character code sets are supported.
Using quotaoff to disable quotas on a file system causes the system to
discontinue tracking quotas for that file system, and marks the quota
clean flag in the superblock NOT_OK (see fsclean(1M)). This in turn,
forces a quotacheck the next time the system is booted. Since quotas
are enabled and disabled cleanly by mount and umount anyway, the use
of quotaon and quotaoff is generally discouraged.
Disk quotas were developed by the University of California, Berkeley,
Sun Microsystems, Inc., and HP.
/etc/fstab Static information about the file systems
/etc/mnttab Mount file system table
directory/quotas Quota statistics storage for the file system,
where directory is the root of the file
system as specified to the mount command (see
fsclean(1M), quotacheck(1M), quotacheck_hfs(1M), quotacheck_vxfs(1M),
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000