pwd_strengthd(1m) OSF pwd_strengthd(1m)
pwd_strengthd - The sample Password Management Server
pwd_strengthd [+/-all[_spaces]] [+/-alp[ha_num]]
[-c[ache_size]] size [-d[ebug]]
[-m[in_len]] pwd_min_len [-t[imeout]] minutes
Allow passwords to be all spaces. If this option is not set,
the effective registry policy is used.
Disallow passwords to be all spaces. If this option is not
set, the effective registry policy is used.
Allow passwords to consist only of alphanumeric characters.
If this option is not set, the effective registry policy is
Disallow passwords to consist only of alphanumeric
characters. If this option is not set, the effective
registry policy is used.
Specify the number of hash buckets in the password cache.
The password cache is used to store generated passwords
which are retrieved when the password is strength checked.
The password cache is a hash table with a linked list for
collisions. The size should be set to a reasonable value
based on how large the cache will be on average. The default
value if not specified is 100.
-debug Run in the foreground. Log messages are written to standard
Specify the minimum length of a password. If this option is
not set, the effective registry policy is used.
Specify the time, in minutes, that generated passwords
remain in the cache before they are deleted from memory. If
this option is not specified, the default time is 30
Hewlett-Packard Company - 1 - OSF DCE 1.1/HP DCE 1.8
pwd_strengthd(1m) Open Software Foundation pwd_strengthd(1m)
-verbose Runs in verbose mode. More detailed messages are sent to the
logfile $DCELOCAL/var/security/pwd_strengthd.log. (Use of
this option is recommended.)
pwd_strengthd is a sample Password Management Server. It exports the
rsec_pwd_mgmt application programming interface.
pwd_strengthd generates passwords and strength-checks them. It
enforces the security registry policy for password strength-checking.
Administrators can override the security registry policy via the
command-line options (alpha_num, all_spaces, min_len.)
Administrators can subject principals to password-strength and
-generation policies by attaching the following ERAs:
Specifies the password management policy the user must conform
to when selecting passwords.
Specifies information required in order to connect to the
password management server.
See the OSF DCE Administrator's Guide -- Core Services for more
information and examples.
NOTE: You may want to enhance pwd_strengthd to support your
site's policies for password strength and generation.
Hewlett-Packard Company - 2 - OSF DCE 1.1/HP DCE 1.8