pdfdiff - compare two Product Description Files
pdfdiff [-n] [-p percent] pdf1 pdf2
pdfdiff is a program that compares two PDFs (Product Description
Files). The PDFs can be generated using the mkpdf command (see
mkpdf(1M)). Individual fields in the PDFs are compared, and
differences found in these fields are reported. For a detailed
explanation of the PDF fields see pdf(4).
The report format is:
pathname: diff_field[(details) ][ ,...]
diff_field is one of the field names specified in pdf(4). The format
of details is ``oldvalue -> newvalue'' and may include an additional
A summary of total product growth in bytes, DEV_BSIZE disk blocks, and
the percentage change in disk blocks is reported. This summary
includes growth of all files, including those for which growth did not
exceed the threshhold percent. Format of the growth summary is:
Growth: x bytes, y blocks (z%)
pdfdiff recognizes the following options:
-n Compare numerical representation of user ID uid
and group ID gid of each file, instead of the
usual text representation. If owner or group is
recorded in the PDF as a name, look the name up in
the /etc/passwd or /etc/group file, respectively,
to find the ID number.
-p percent specifies a threshhold percentage for file growth.
Files having a net size change greater than or
equal to this percentage are reported. A decrease
in size is reported as a negative number. If -p
is not specified, a default value of zero percent
The following output results when the /usr/bin/cat entry in the
example from pdf(4) is different in the compared PDF:
/usr/bin/cat: mode(-r-xr-xr-x -> -r-sr-xr-x)(became suid), size(27724 -> 10345),
checksum(1665 -> 398)
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
Growth: -17379 bytes, -17 blocks (-4%)
Use of PDFs is discouraged since this functionality is obsolete and is
being replaced with Software Distributor (see sd(4)).
mkpdf(1M), pdfck(1M), pdf(4).
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000