newfs - construct a new file system
/usr/sbin/newfs [-F FStype] [-o specific_options] [-V] special
The newfs command is a "friendly" front-end to the mkfs command (see
mkfs(1M)). The newfs command calculates the appropriate parameters
and then builds the file system by invoking the mkfs command.
special represents a character (raw) special device.
newfs recognizes the following options:
-F FStype Specify the file system type on which to operate
(see fstyp(1M) and fs_wrapper(5)). If this option
is not included on the command line, then the file
system type is determined from the file /etc/fstab
by matching special with an entry in that file.
If there is no entry in /etc/fstab, then the file
system type is determined from the file
Specify options specific to the file system type.
specific_options is a list of suboptions and/or
keyword/attribute pairs intended for an FStype-
specific module of the command. See the file
system specific manual entries for a description
of the specific_options that are supported, if
-V Echo the completed command line, but perform no
other actions. The command line is generated by
incorporating the specified options and arguments
and other information derived from /etc/fstab.
This option allows the user to verify the command
Execute the newfs command to create an HFS file system on
newfs -F hfs /dev/rdsk/c1t0d2
newfs was developed by HP and the University of California, Berkeley.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
/etc/default/fs File that specifies the default file system
/etc/fstab Static information about the file systems.
fsck(1M), fstyp(1M), mkfs(1M), newfs_hfs(1M), newfs_vxfs(1M),
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000