newarray - configure a disk array
newarray [-NConfig_Name | -rRAID_Level] [Options] device_file
newarray, a front-end program for the utility cfl (see cfl(1M)),
facilitates the configuration of Hewlett-Packard SCSI disk arrays. It
is the recommended utility for all array configuration. Array
configuration maps a set of one or more physical disk mechanisms in an
array to a set of one or more logical disks, addressable by HP-UX.
Logical disks are addressed through device files. Each logical disk in
an array (also known as a LUN, for Logical UNit), has its own device
file. A logical disk can consist of a single physical disk, a portion
of a single physical disk, multiple physical disks, or portions of
multiple physical disks. For additional information about possible
array configurations, see the array configuration table contained in
the file /etc/hpC2400/arraytab, and arraytab(4).
Supported configurations for the array device are pre-defined in the
array configuration table, located in file /etc/hpC2400/arraytab.
newarray can configure a complete set of logical partitions for an
array in one operation. Due to the inter-dependency of logical
partitions, this is the recommended method for configuration. A
single logical partition can be added to an array configuration using
an entry from the array configuration table by using the -L option.
device_file is a character device file that specifies the I/O address,
and driver to use when configuring the disk array. The way that this
file is used by newarray is system dependent. See dependencies below.
Logical partitions in an array are independently addressable by using
the appropriate device file to address the logical unit assigned to a
Prior to configuring the array (except with the -L option ), all
currently configured logical partitions are removed from the
To simplify array configuration newarray obtains much of the necessary
information directly from the array device, and its attached disk
mechanisms. The array model number, and the number of available
physical disks available, is determined by querying the device. This
information is used to locate the appropriate configuration entry in
the array configuration table. Optional parameters can be used to
override the default, and inquiry values.
The preferred configuration method is to use the -N option to specify
a configuration by name. The name determines which configuration
newarray uses from the array configuration table. Configuration
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
parameters are obtained from the named configuration entry.
Parameters of the chosen configuration can be overridden using options
to newarray, or by creating and using a custom configuration entry in
the array configuration table. See the WARNINGS section of this
Because the array controller type, and disk mechanism types are used
in addition to the configuration name to select an entry from the
array configuration table the configuration name does not have to be
unique within the array configuration table. However, the combination
of configuration name, array controller type, and disk mechanism types
must be unique within the array configuration table. During
configuration, the array controller type, and disk mechanism types are
obtained by querying the devices.
The -r option specifies an operating mode, rather than specifying a
configuration by name. The -d option, which specifies the size of a
disk group, is often used with the -r option. If -d is not used,
newarray selects the configuration in the array configuration table
that most closely matches the disks in the array.
When the configuration parameters have been determined, newarray calls
If the -V option is used, newarray prints its actions, and the
parameters it passes to cfl to configure the array (see cfl(1M)).
newarray obtains its configuration values from the array configuration
table. If not specified there, default values are provided by cfl
(see cfl(1M)). Configuration values can be overridden by newarray
-L unit addr Configures a single LUN from the specified
configuration. The -L option is useful for adding
disks to an array without changing the existing
configuration. Because the order in which LUN's are
configured determines the physical mapping on the disks
within the array, be very careful when using the -L
-N config_name The name of the configuration to be used, as specified
in the configuration file /etc/hpC2400/arraytab. See
-V Display the parameters of array configuration, and the
utility commands issued as part of the configuration
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
-b block_size The size in bytes of the LUN block. Must be an
integral number of the physical disk mechanism sector
size. Currently supported values are 512, 1024, 2048,
-c capacity The size in blocks of the LUN. A value of 0 defaults
to the largest capacity available. If the LUN type is
set to sub-LUN, the capacity is the available capacity
of the composite drive group or 2 GByte if the 2 GByte
flag is set, which ever is smaller. See -f option.
-d group_size Physical drive group will contain this number of disks
in the logical partition configuration.
-f flags Configuration flags. There are 16 flags, represented
by a 16 bit hexadecimal number. Currently only four of
the flags are defined. The flag definitions and their
default value are:
Bit 0 off Not used.
Bit 1 on Disable auto reconstruction. When set
(on), disables the automatic detection,
and initiation of failed disk data
Bit 2 off Not used.
Bit 3 off Not used.
Bit 4 on When set (on), enables AEN (automatic
event notification) polling.
Bit 5 on When set (on), enables read parity
Bit 6 on When set (on), enables write with
Bit 7 off Not used.
Bit 8 off Mode Sense default pages. Bit 8 and
Bit 9 concurrently set is reserved.
Bit 9 off Mode Sense current pages. Bit 8 and
Bit 9 concurrently set is reserved.
Bit 10-15 off Not used.
-g group_name Use physical drive group configuration with label
GroupName (in array configuration table) for this LUN
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000
-i seg0_size The size in bytes of the first segment LUN. This
allows this area to be set to a size different than the
remainder of the disk, an area typically used as the
boot block for some systems. This must be a integral
number of the block-size. If there are no special
requirements, this parameter should be set to 0.
-k recon_size Reconstruction size. The -k option specifies (in LUN
blocks) the amount of data to be reconstructed in a
single operation during reconstruction of a redundant
drive configuration. Larger values provide more
efficient (faster) reconstruction, but hold off the
servicing of I/O requests. Smaller values allow
quicker servicing of I/O requests, but with less
efficient (slower) reconstruction.
-l recon_freq Reconstruction frequency. The -l option specifies (in
tenths of a second) the time period between
reconstruction of disk segments in a redundant drive
configuration. Small time periods cause the array to
consume most of its time reconstructing data, but allow
the reconstruction to complete more quickly. Large
time periods allocate more time to I/O processing, but
require longer reconstruction times.
-r raid_level The RAID (redundancy level) to apply to the disks in
the array. Valid entries for raid_level are RAID_0,
RAID_1, RAID_3, and RAID_5. Some RAID levels require
specific physical drive configurations. See also the
-s seg_size The number of bytes of a contiguous segment of the
logical address space residing on a single physical
disk. This affects how many physical disks are
involved in a single I/O request. If I/O requests are
mostly random, single-block requests, set this value to
the integral number of the LUN block size that
minimizes the number of disks necessary to service most
I/O requests. A larger size will allocate more time to
-t LUN_type LUNs can be configured as regular LUNs (reg), or sub-
LUNs (sub). A regular LUN utilizes all the available
capacity of a disk group, or limits the LUN
configuration to 2 GBytes if the 2 GByte limiter is
set. If a regular LUN configuration is used, the -c
option is ignored. A sub-LUN allows logical
partitioning of the disk group capacity into a maximum
of eight LUNs. Valid values for LUN_type are "reg" and
Hewlett-Packard Company - 4 - HP-UX Release 11i: November 2000
You can create array configurations that might be better suited to a
particular application by using newarray's command line parameters to
override default values, or by creating special entries in the array
configuration table in the file /etc/hpC2400/arraytab. Before you do,
see cautionary notes in the WARNINGS section of this manpage.
newarray will return the following values:
0 Successful completion.
-1 Command failed (an error occurred).
newarray: device busy
To ensure that newarray does not modify a disk array that is being
used by another process, newarray attempts to obtain exclusive access
to the disk array. If the disk array is already opened by another
process (for example, LVM - the Logical Volume Manager), a ``device
busy'' error message is returned by the driver. To eliminate the
``device busy'' condition, determine what process has the device open.
In the case of LVM, it is necessary to deactivate the volume group
containing the array before configuring the array (see vgchange(1M)).
The following examples use configurations contained in
Raid Level Specification
To configure an HP C2425D with 5 internal disks to a five drive RAID
level 0 configuration (on Series 700 computer):
newarray -rRAID_0 /dev/rdsk/c2t3d0
To configure an HP C2425D with 5 internal disks to a one drive RAID
level 0 configuration (on Series 700):
newarray -rRAID_0 -d1 /dev/rdsk/c2t3d0
To configure an HP C2430D with five disks connected on SCSI channel 3
(on a Series 800) using the configuration "Raid_3_5d" in
newarray -NRaid_3_5d /dev/rdsk/c2t3d0
We strongly recommend that you use the array configurations that are
Hewlett-Packard Company - 5 - HP-UX Release 11i: November 2000
specified, and delivered by Hewlett-Packard, in the file
/etc/hpC2400/arraytab. These configurations have been tested and
certified for proper use on Hewlett-Packard computer systems. Custom
configurations cannot be warranted for proper operation.
Configuring a disk array causes the loss of user data on the array.
When using the -L option, physical media is assigned to the logical
unit in the order in which the logical units are configured. Existing
logical unit configurations are NOT removed prior to configuration
with this option. The use of this option is not recommended at this
File System Considerations
The disk array maps the address space of one or more physical disk
mechanisms onto logical "disk" partitions. The parameters defined in
the configuration, together with the data access patterns of the
user's application, determine the operating characteristics of the
logical disk. Some configurations create multiple logical partitions,
that share a set of physical disks. I/O traffic to each of the
logical partitions affects performance, due to the common physical
disk resources. The file system or application using the "logical"
disk may require or assume certain characteristics. For optimal
system performance it is necessary that the file system configuration
and application be compatible with the array configuration.
Your choice of segment size directly affects the performance of the
disk array. Choose this parameter in concert with the choice of the
parameters used when building the file system on the device. In
general, the segment size determines how much data from a single I/O
will be stored on a single disk within the array. A smaller value
will involve more of the disks with the I/O, whereas a larger value
will involve fewer disks. If input/output operations tend to be very
long, the involvement of multiple disks may hasten the completion of
each I/O. In this case the access time is the same as a single disk,
but the disk data transfer time is shared across the set of disks. If
input/output operations are short, the access time will dominate
relative to the disk data transfer time, and more input/output
operations may be processed in parallel by involving fewer disks in
each I/O. In all cases the relative locality of data and the access
pattern will affect the performance. For highly sequential data, it
may be advantageous to locate the data for a single I/O on a single
disk, to take advantage of read-ahead caching within each disk.
Configurations for the HP C2430 disk array should enable the automatic
data reconstruction LUN flag as part of the configuration
Supported Array Products:
Hewlett-Packard Company - 6 - HP-UX Release 11i: November 2000
The HP C2425 and HP C2427 disk arrays are only supported on Series 700
systems running HP-UX version 9.0X.
The HP C2430 disk array is supported on Series 700 and 800 systems
running HP-UX versions 9.0X and 10.0X.
newarray was developed by HP.
arraytab(4), cfl(1M), buildfs(1M), fs(4), mkfs(1M), sss(1M), dcc(1M).
Hewlett-Packard Company - 7 - HP-UX Release 11i: November 2000