named-xfer - ancillary agent for inbound zone transfers
named-xfer -z zone_to_transfer -f db_file -s serial_no [-d debuglevel]
[-t trace_file] [-p port#] [-S] nameserver...
named-xfer is an ancillary program executed by named(1M) to perform an
inbound zone transfer. It is rarely executed directly, and then
generally by system administrators trying to debug a zone transfer
problem. See RFC's 1033, 1034, and 1035 for more information on the
Internet name-domain system.
-z specifies the name of the zone to be transferred.
-f specifies the name of the file into which the zone should be
dumped when it is received from the primary server.
-s specifies the serial number of the current copy of the zone
selected for transfer. If the SOA resource record received from
the specified remote nameserver(s) does not have a serial number
higher than one specified with this option, the transfer will be
-d Print debugging information. A number after the d determines the
level of messages printed.
-l Specifies a log file for debugging messages. The default file
uses the prefix xfer.ddt. and is located in the /var/tmp
directory. Note this option only applies if -d is also
-t Specifies a trace file which will contain a protocol trace of the
zone transfer. This is probably only of interest when debugging
the name server itself.
-p Use a different port number. The default is the standard port
number as returned by getservbyname(3) for service ``domain''.
-S Perform a restricted transfer of only the SOA, NS and glue A
records for the zone. The SOA will not be loaded by named, but
will be used to determine when to verify the NS records. See the
stubs directive in named(1M) for more information.
Additional arguments are taken as name server addresses in so-called
``dotted-quad'' syntax only; no host name are allowed here. At least
one address must be specified. Any additional addresses will be tried
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
in order if the first one fails to transfer to us successfully.
0 Indicates that the zone was up-to-date and no transfer was
1 Indicates a successful transfer.
2 Indicates that the host(s) named-xfer queried cannot be reached
or that an error occurred and named-xfer did not log a
corresponding error message.
3 Indicates that an error occurred and named-xfer logged an error
named-xfer was developed by the University of California, Berkeley.
named(1M), resolver(3N), resolver(4), hostname(5).
RFC 882, RFC 883, RFC 973, RFC 974, RFC 1033, RFC 1034, RFC 1035, RFC
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000