makemap - creates database maps for sendmail
makemap [-N] [-n] [-d] [-f] [-o] [-r] [-s] [-v] maptype mapname
makemap creates the database maps used by the keyed map lookups in
sendmail(1M). It reads input from the standard input and outputs them
to the indicated mapname.
makemap handles up to three different database formats, selected using
the maptype parameter. They may be
dbm DBM format maps. (.pag,.dir)
btree B-Tree format maps. (.db)
hash Hash format maps. (.db)
In all cases, makemap reads lines from the standard input consisting
of two words separated by white space. The first is the database key,
the second is the value. The value may contain %n strings to
indicated parameter substitution. Literal parentheses should be
doubled (%%). Blank lines and lines beginning with pound sign (#) are
-N Include the null byte that terminates strings in the map.
This must match the -N flag in the sendmail.cf K line.
-n Create NIS compatible alias database.
-d Allow duplicate keys in the map. This is only allowed on B-
Tree format maps. If two identical keys are read, they will
both be inserted into the map.
-f Normally all upper case letters in the key are folded to lower
case. This flag disables that behaviour. This is intended to
mesh with the -f flag in the K line in sendmail.cf. The value
is never case folded.
-o Append to an old file. This allows you to augment an existing
-r Allow replacement of existing keys. Normally makemap
complains if you repeat a key, and does not do the insert.
-s Ignore safety checks on maps being created. This includes
checking for hard or symbolic links in world writable
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
-v Verbosely print what it is doing.
The makemap command appeared in 4.4BSD.
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000