getty - set terminal type, modes, speed, and line discipline
/usr/sbin/getty [-h] [-t timeout] line [speed [type [linedesc]]]
/usr/sbin/getty -c file
getty is a program that is invoked by init(1M). It is the second
process in the series, (init-getty-login-shell) that ultimately
connects a user with the HP-UX system. Initially, if /etc/issue
exists, getty prints its contents to the user's terminal, followed by
the login message field for the entry it is using from /etc/gettydefs.
getty reads the user's login name and invokes the login(1) command
with the user's name as argument. While reading the name, getty
attempts to adapt the system to the speed and type of terminal being
Configuration Options and Arguments
getty recognizes the following arguments:
line Name of a tty line in /dev to which getty is to
attach itself. getty uses this string as the name of
a file in the /dev directory to open for reading and
writing. By default getty forces a hangup on the
line by setting the speed to zero before setting the
speed to the default or specified speed. However,
when getty is run on a direct port, getty does not
force a hangup on the line since the driver ignores
changes to zero speed on ports open in direct mode
-h Tells getty not to force a hangup on the line before
setting the speed to the default or specified speed.
-t timeout getty exits if the open on the line succeeds and no
one types anything within timeout seconds.
speed A label to a speed and tty definition in the file
/etc/gettydefs. This definition tells getty at what
speed to initially run, what the login message should
look like, what the initial tty settings are, and
what speed to try next should the user indicate that
the speed is inappropriate (by typing a break
character). The default speed is 300 baud.
type A character string describing to getty what type of
terminal is connected to the line in question. getty
understands the following types:
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
vt61 DEC vt61
vt100 DEC vt100
hp45 Hewlett-Packard HP2645
c100 Concept 100
The default terminal is none; i.e., any crt or normal
terminal unknown to the system. Also, for terminal
type to have any meaning, the virtual terminal
handlers must be compiled into the operating system.
They are available, but not compiled in the default
linedesc A character string describing which line discipline
to use when communicating with the terminal. Hooks
for line disciplines are available in the operating
system, but there is only one presently available -
the default line discipline, LDISC0.
When given no optional arguments, getty sets the speed of the
interface to 300 baud, specifies that raw mode is to be used (awaken
on every character), that echo is to be suppressed, either parity
allowed, new-line characters will be converted to carriage return-line
feed, and tab expansion performed on the standard output. It types
the login message before reading the user's name a character at a
time. If a null character (or framing error) is received, it is
assumed to be the result of the user pushing the ``break'' key. This
causes getty to attempt the next speed in the series. The series that
getty tries is determined by what it finds in /etc/gettydefs.
The user's name is terminated by a new-line or carriage-return
character. The latter results in the system being set to treat
carriage returns appropriately (see ioctl(2)).
The user's name is scanned to see if it contains any lowercase
alphabetic characters; if not, and if the name is non-empty, the
system is told to map any future uppercase characters into the
corresponding lowercase characters.
getty also understands the ``standard'' ESS2 protocols for erasing,
killing and aborting a line, and terminating a line. If getty sees
the ESS erase character, _, or kill character, $, or abort character,
&&&&, or the ESS line terminators, / or !, it arranges for this set of
characters to be used for these functions.
Finally, login is called with the user's name as an argument.
Additional arguments can be typed after the login name. These are
passed to login, which places them in the environment (see login(1)).
A check option is provided. When getty is invoked with the -c option
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
and file, it scans file as if scanning /etc/gettydefs and prints the
results on the standard output. If there are any unrecognized modes
or improperly constructed entries, getty reports these. If the
entries are correct, getty prints out the values of the various flags.
See ioctl(2) for an interpretation of values. Note that some values
are added to the flags automatically.
The modem control parameter MRTS must be present in the /etc/gettydefs
file when using getty in conjunction with an HP2334 or HP2335 MultiMux
to ensure that the RTS modem control signal is asserted correctly.
9600# B9600 HUPCL PARENB MRTS # B9600 SANE PARENB ISTRIP IXANY #login: #19200
MRTS is not intended for use with devices other than the HP2334 or
ct(1), login(1), init(1M), ioctl(2), gettydefs(4), inittab(4),
While getty does understand simple single character quoting
conventions, it is not possible to quote the special control
characters that getty uses to determine when the end of the line has
been reached, which protocol is being used, and what the erase
character is. Therefore it is not possible to log in by means of
getty and type a #, @, /, !, _, backspace, ^U, ^D, or &&&& as part of
your login name or arguments. They will always be interpreted as
having their special meaning as described above.
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000