dceping(8) HP DCE dceping(8)
dceping - test the ability to contact DCE services from a local DCE
dceping [-n number] [-s time] [-v] [-C] [service_name ...] required to
specify the literal strings, NAMESPACE or STRING_BINDING (see
-n number Specify the number of pinging cycles. Each service is tested
once per cycle. The default is one pinging cycle. Specifying
-n 0 makes pinging continuous.
-s time Specify time, in seconds, to wait between pinging cycles.
You must specify more than one pinging cycle with the -n
option in order to use -s.
-v Run in verbose mode.
-C Ping only core DCE services. This option is ineffective if a
service_name is specified on the command line.
dceping verifies that a local DCE client can communicate with DCE and
other services. It uses the RPC management interface to determine if
the DCE service is listening. The core DCE services that dceping
checks include secd, cdsd, gdad, rpcd, cdsadv, dtsd, and sec_clientd.
You can ping other DCE and non-DCE services by naming them in the
file, /opt/dcelocal/hpadmin/etc/nondcesvc. If you want to determine at
run time what services you want dceping to ping, you may do so using
the same file. See the manpage, nondcesvc(4), for more information.
You may specify the services to ping on the command line separated by
blanks. In this case, dceping does not ping any DCE core services or
the services listed in /opt/dcelocal/hpadmin/etc/nondcesvc. The
service_name specified could be either a name in the DCE Cell
Directory Service Namespace or an RPC string binding. It is not
dceping was developed by HP.
Hewlett-Packard Company - 1 - HP DCE/9000 Version 1.2