Series 800 Only
cuegetty - set terminal type, modes, speed, and line discipline for
/usr/sbin/cuegetty [-L nls_language] [-T terminal_type] [-h] [-t
timeout] line [speed]
The cuegetty, command, which is very similar to getty(1M), is the
second process in the series, (init-cuegetty-cue-work session) that
ultimately connects a user with the HP-UX CUE system. It is invoked
by init to monitor the terminal lines configured on a system (see
init(1M)). Each cuegetty process resets its process group using
setpgrp, opens a particular terminal line, and usually sleeps in the
open() until the machine senses a hardware connection for the
terminal. When open() returns, cuegetty attempts to adapt the system
to the terminal speed and type, and displays the contents of the
/etc/issue file, if it exists. Lastly, cuegetty invokes cue which
displays the Login screen and performs user validation (see cue(1)).
To start cuegetty, an entry for cuegetty should be placed in the
/etc/inittab file. A typical CUE entry in the /etc/inittab file
resembles the following:
cue:2:respawn:/usr/sbin/cuegetty -L fr_FR.roman8 -h tty0p1
See /usr/newconfig/etc/cue.inittab for an example /etc/inittab file.
See cue(1) for more details on the CUE system.
Configuration Options and Arguments
cuegetty recognizes the following arguments:
line Name of a tty line in /dev to which cuegetty is to
attach itself. cuegetty uses this string as the name
of a file in the /dev directory to open for reading
and writing. By default cuegetty forces a hangup on
the line by setting the speed to zero before setting
the speed to the default or specified speed.
However, when cuegetty is run on a direct port,
cuegetty does not force a hangup on the line since
the driver ignores changes to zero speed on ports
open in direct mode (see modem(7)).
-L nls_language is used to set the language for the CUE
login screens. If the message catalog, cue.cat, does
not exist for nls_language, the default native
language, C, is used.
-T terminal_type is used to specify the type of terminal
that cuegetty will be initiated on. Allowed values
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
Series 800 Only
are vt320, vt100, wy60, and hp. The default is hp.
-h Tells cuegetty not to force a hangup on the line
before setting the speed to the default or specified
-t timeout cuegetty exits if the open on the line succeeds and
nothing is typed within timeout seconds.
speed A label to a speed and tty definition in the file
/etc/gettydefs. This definition tells cuegetty at
what speed to initially run, what the login message
should look like, what the initial tty settings are,
and what speed to try next should the user indicate
that the speed is inappropriate (by typing a break
character). The default speed is 300 baud.
When no optional arguments appear on the command line, cuegetty
sets the terminal interface as follows:
+ Interface speed: 300 baud
+ Raw mode (awaken on every character)
+ Echo suppressed
+ Parity: either
+ New-line characters: convert to carriage-return, line-
+ Expand tabs on the standard output
+ Type login message then read user's name, one character
at a time
+ If a null character (or framing error) is received,
assumed it to be the result of the user pushing the
``break'' key. This causes cuegetty to attempt the next
speed in the series. The series that cuegetty tries is
determined by what it finds in /etc/gettydefs.
After interface set-up is complete, cue is started to accept and
validate the user name and password.
If a supported non-HP terminal (or an HP terminal such as HP 700/60 in
VT320, VT100 or WYSE60 mode) is required to run cuegetty, make sure
that a correct terminal type is specified using the -T option. For
example, if you want to run cuegetty on a vt100 terminal, you should
make an entry in the /etc/inittab file such as the following entry:
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000
Series 800 Only
tty1:23:respawn:cuegetty -T vt100 -h tty1p1 9600
Absence of the -T option causes cuegetty to assume terminal to be a HP
terminal which may then cause the terminal to behave incorrectly and
may not even allow user to login.
cuegetty is available only on Series 800 systems, and is compatible
only with the following terminals:
HP700/92 HP700/94 HP2392 HP2394 VT100 WYSE60
See WARNINGS if you intend to use a non-HP terminal (or an HP terminal
such as HP 700/60 in VT320, VT100, or WYSE60 mode).
/etc/gettydefs contains speed and terminal settings used by
/etc/inittab init reads this file to determine which
processes to spawn
/etc/issue contains issue identification data
sample inittab file with cuegetty entry
cue(1), env(1), nlsinfo(1), getty(1M), init(1M), ioctl(2),
gettydefs(4), inittab(4), environ(5), hpnls(5), lang(5), termio(7).
Hewlett-Packard Company - 3 - HP-UX Release 11i: November 2000