create child(1m) OSF create child(1m)
create child - Creates a child pointer at the master replica of the
cdscp create child child-name clearinghouse clearinghouse-name
The full name of the child pointer.
The full name of a clearinghouse that contains a replica of
the child directory.
The create child command creates a child pointer at the master replica
of the parent directory. When CDS looks up a name in the namespace,
it uses child pointers to locate directory replicas. Use the set cdscp
preferred clearinghouse command before issuing this command to ensure
that the request is directed to the master replica.
You must have insert permission to the parent directory.
Use the create child command only to re-create a child pointer that is
accidentally deleted. This command is designed only for
This command will fail if the associated directory does not exist. If
the associated directory exists, this command will return
This command is replaced at Revision 1.1 by the dcecp command and may
not be provided in future releases of DCE.
The following command creates the child pointer in the parent
directory /.:/subsys. It uses the replica located at the
/.:/subsys/NY_CH clearinghouse to fill in its replica set.
dscp>>>> create child /.:/subsys clearinghouse /.:/subsys/NY_CH
Commands: delete child(1m), list child(1m), show child(1m)
Hewlett-Packard Company - 1 - OSF DCE 1.1/HP DCE 1.8