clri - clear inode
/usr/sbin/clri special i-number ...
The clri command clears the inode i-number by filling it with zeros.
special must be a special file name referring to a device containing a
file system. For proper results, special should not be mounted (see
WARNINGS below). After clri is executed, all blocks in the affected
file show up as "missing" in an fsck of special (see fsck(1M)). This
command should only be used in emergencies.
Read and write permission is required on the specified special device.
The inode becomes allocatable.
The primary purpose of this command is to remove a file that for some
reason does not appear in any directory. If it is used to clear an
inode that does appear in a directory, care should be taken to locate
the entry and remove it. Otherwise, when the inode is reallocated to
some new file, the old entry in the directory will still point to that
file. At that point, removing the old entry destroys the new file,
causing the new entry to point to an unallocated inode, so the whole
cycle is likely to be repeated again.
If the file system is mounted, clri is likely to be ineffective.
clri operates only on file systems of type hfs.
fsck(1M), fsdb(1M), ncheck(1M), fs(4).
clri: SVID2, SVID3
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000