bootpquery - send BOOTREQUEST to BOOTP server
/usr/sbin/bootpquery haddr [htype] [options]
bootpquery is a diagnostic function used to check the configuration of
the Internet Bootstrap Protocol (BOOTP) server, bootpd(1M). This
function can only be run by the superuser, since it uses reserved
bootpquery constructs a boot request with the supplied parameters to
send to the BOOTP server, and prints the contents of the BOOTP server
reply (as shown in EXAMPLES, below). Note that bootpquery formats and
prints RFC-1048 or CMU-style vendor information included in the
The BOOTREQUEST packet is broadcast on the BOOTP server port, bootps.
If a BOOTP server is configured to respond to the request, it returns
a BOOTREPLY packet on the BOOTP client port, bootpc. bootpquery can
only display BOOTREPLY packets when the BOOTP server broadcasts the
reply on the client port or when the hardware address and IP address
supplied in the BOOTREQUEST are those of the host on which bootpquery
The following options provide the information for the BOOTREQUEST:
haddr Hardware address of the BOOTP client; used in the
BOOTREQUEST. A BOOTP server responds if it has
configuration information for a host with this link-level
htype Type of address specified as haddr; may be ether or
ieee802. The default address type is ether.
Specify the internet address of the BOOTP client to be
used in the BOOTREQUEST. If the BOOTP client does not
know its IP address, the BOOTP server supplies it in the
BOOTREPLY. Otherwise, the server returns the BOOTREPLY
directly to ipaddr.
Specify the name of the BOOTP server to receive
BOOTREQUEST. When the BOOTP server is known, the
BOOTREQUEST is not broadcast.
Specify a vendor name to include vendor information in
the BOOTREPLAY. vendor can be specified as rfc1048 or
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
cmu. For any other vendor specification, the first four
characters of the parameter are used as the vendor magic
-f Specify that bootpd should broadcast the reply back. This
option is only valid for bootpd on the HPUX 10.0 (or
Specify a boot file needed by the BOOTP client. If a
boot file is specified in the BOOTREQUEST, the BOOTP
server responds only if the server host can make the file
/usr/sbin/bootpquery 02608cee018e ether -s hpserver
Received BOOTREPLY from hpserver.hp.com (188.8.131.52)
Hardware Address: 02:60:8c:ee:01:8e
Hardware Type: ethernet
IP Address: 184.108.40.206
Boot file: /export/tftpdir/hp-gw2-confg
RFC 1048 Vendor Information:
Subnet Mask: 255.255.248.0
Bootfile Size: 6 512 byte blocks
Domain Name Server: 220.127.116.11
Host Name: hp-gw2
bootpquery was developed by HP.
bootpd(1M), tftp(1), tftpd(1M).
DARPA Internet Request For Comments RFC951, RFC1048, RFC1084, RFC1395,
RFC1542 Assigned Numbers.
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000