add directory(1m) OSF add directory(1m)
add directory - Adds a value to a modifiable, set-valued attribute
(including application-defined attributes) of a directory
cdscp add directory directory-name attribute-name = attribute-value
The full name of the directory.
The name of a particular attribute. Specify only one
attribute at a time. See the cds_attributes file for the
list of attributes that your application uses.
attribute-value The value of a particular attribute. The
value of an application-defined attribute is dependent on
the type of attribute. See the cds_attributes file for the
list of attributes and corresponding data types that your
application uses. If you enter a byte data type, you must
enter an even number of digits in length. You can only
enter pairs of hexadecimal values for user-defined
The add directory command adds a value to a modifiable, set-valued
attribute (including application-defined attributes) of a directory.
If the attribute does not exist, this command creates it. Usually,
this task is performed through the client application. See the DCE
Administration Guide for more information about attributes.
You must have write permission to the directory.
This command is replaced at Revision 1.1 by the dcecp command and may
not be provided in future releases of DCE.
To add the value ontario to the attribute myname of a directory named
/.:/sales, read the cds_attributes file to verify that the attribute
shown in the following display exists:
OID LABEL SYNTAX
18.104.22.168.3.91 myname char
Hewlett-Packard Company - 1 - OSF DCE 1.1/HP DCE 1.8
add directory(1m) Open Software Foundation add directory(1m)
Enter the following command to assign the value ontario to the
dscp>>>> add directory /.:/sales myname = ontario
Commands: remove directory(1m), show directory(1m)
Books: OSF DCE Administration Guide
Hewlett-Packard Company - 2 - OSF DCE 1.1/HP DCE 1.8