acctprc, acctprc1, acctprc2 - process accounting
acctprc1 reads input in the form described by acct(4), adds login
names corresponding to user IDs, then writes for each process an ASCII
line giving user ID, login name, prime CPU time (tics), non-prime CPU
time (tics), and mean memory size (in memory segment units). If ctmp
is given, it is expected to contain a list of login sessions in the
form described in acctcon(1M), sorted by user ID and login name. If
this file is not supplied, it obtains login names from the password
file. The information in ctmp helps it distinguish among different
login names that share the same user ID.
acctprc2 reads records in the form written by acctprc1, summarizes
them by user ID and name, then writes the sorted summaries to the
standard output as total accounting records.
acctprc combines the functionality of acctprc1 and acctprc2 into one
program. It takes the same input format as acctprc1 (but does not
accept the ctmp argument) and writes the same output as acctprc2.
These commands are typically used as shown below:
acctprc1 ctmp <<<< /var/adm/pacct | acctprc2 >>>> ptacct
acctprc <<<< /var/adm/pacct >>>> ptacct
For the output of acctprc2, if the user IDs are identical, LC_COLLATE
determines the order in which the user names are sorted.
If LC_COLLATE is not specified in the environment or is set to the
empty string, the value of LANG is used as a default. If LANG is not
specified or is set to the empty string, a default of ``C'' (see
lang(5)) is used instead of LANG. If any internationalization
variable contains an invalid setting, acctprc2 behaves as if all
internationalization variables are set to ``C'' (see environ(5)).
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
acct(1M), acctcms(1M), acctcom(1M), acctcon(1M), acctmerg(1M),
acctsh(1M), cron(1M), fwtmp(1M), runacct(1M), acct(2), acct(4),
Although it is possible to distinguish among login names that share
user IDs for commands run normally, it is difficult to do this for
those commands run from cron for example (see cron(1M)). More precise
conversion can be done by faking login sessions on the console via the
acctwtmp program in acct(1M).
A memory segment of the mean memory size is a unit of measure for the
number of bytes in a logical memory segment on a particular processor.
acctprc1: SVID2, SVID3
acctprc2: SVID2, SVID3
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000