acctcms - command summary from per-process accounting records
/usr/sbin/acct/acctcms [options] files
acctcms reads one or more files, normally in the form described in
acct(4). It adds all records for processes that executed
identically-named commands, sorts them, and writes them to the
standard output, normally using an internal summary format.
acctcms recognizes the following options:
-a Print output in ASCII rather than in the internal summary
format. The output includes command name, number of
times executed, total kcore-minutes, total CPU minutes,
total real minutes, mean size (in K), mean CPU minutes
per invocation, ``hog factor'', characters transferred,
and blocks read and written, as in acctcom(1M). Output
is normally sorted by total kcore-minutes.
-c Sort by total CPU time, rather than total kcore-minutes.
-j Combine all commands invoked only once under ***other.
-n Sort by number of command invocations.
-s Any file names encountered hereafter are already in
internal summary format.
-t Process all records as total accounting records. The
default internal summary format splits each field into
prime- and non-prime-time parts. This option combines
the prime and non-prime time parts into a single field
that is the total of both, and provides upward
compatibility with old (i.e., UNIX System V) style
acctcms internal summary format records.
The following options can be used only with the -a option.
-p Output a prime-time-only command summary.
-o Output a non-prime- (offshift) time only command summary.
When -p and -o are used together, a combination prime and non-prime
time report is produced. All the output summaries are total usage
except number of times executed, CPU minutes, and real minutes which
are split into prime and non-prime.
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
A typical sequence for performing daily command accounting and for
maintaining a running total is:
acctcms file ... >>>>today
cp total previoustotal
acctcms -s today previoustotal >>>>total
acctcms -a -s today
Unpredictable output results if -t is used on new-style internal-
summary-format files, or if it is not used with old style internal
summary format files.
acct(1M), acctcom(1M), acctcon(1M), acctmerg(1M), acctprc(1M),
acctsh(1M), fwtmp(1M), runacct(1M), acct(2), acct(4), utmp(4).
acctcms: SVID2, SVID3
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000