Aserver - start the audio server
The Aserver command starts the HP-UX Audio server, which can run on a
system with audio hardware. See Audio(5) for information about which
systems have audio hardware. The -f option forces the starting of the
Audio server; this option is only needed if the Aserver has problems
The Audio Server
Before using any audio tools such as the Audio Editor, the system or X
station must be running two audio server processes, called Aserver.
On a Series 700, the Remote Procedure Call daemon (rpcd) must also be
Normally, the Aserver processes and rpcd start automatically when the
system is booted. If problems occur on an ENTRIA or ENVIZEX X
station, see the X station owner's manual. On a Series 700 Audio
hardware, first check if rpcd is running. Type the following:
ps -e | grep rpcd
If it is running, you see a line similar to the following.
604 ? 0:36 rpcd
If it is not running, see HP 9000/DCE documentation for information on
restarting it. If rpcd is running, verify that the Aserver is
ps -e | grep Aserver
If the Aserver is running you will see lines similar to the following,
which indicate the presence of the two Aserver processes:
1 ? 0:00 Aserver
224 ? 0:00 Aserver
If it is not running, become root and restart it as follows:
If it fails to start, reissue the command with the -f option:
Hewlett-Packard Company - 1 - HP-UX Release 11i: November 2000
Using Audio over the Network
From a workstation, you can also use the Audio Editor and Control
Panel over the network. However, the remote system is where the actual
playback and recording occur.
The local workstation (or audio client) can be any Series 700 system.
The remote system (or audio server) can be a Series 700 or an X
station with audio hardware and must have the Aserver processes
running. If the server is a workstation, it must also allow access
from remote clients (see asecure(1M)) and must have rpcd running.
To make the system an audio client, set the AUDIO variable by
modifying the $HOME/.vueprofile file as follows:
Korn, Bourne, and POSIX Shells: AUDIO=system_name; export
C Shell: setenv AUDIO system_name
For system_name, identify the workstation or X Station running the
If the AUDIO variable is not set, the Audio Library attempts to use to
the Aserver on the system defined by the DISPLAY variable. If neither
DISPLAY nor AUDIO is set, the Aserver on the local machine is used.
The Audio Server must run on a system that has audio hardware. Note
that HP-UX for the 8MB 705 System does not include audio software.
The Audio Server was developed by HP.
audio(5), asecure(1M), attributes(1), convert(1), send_sound(1).
Using the Audio Developer's Kit
Hewlett-Packard Company - 2 - HP-UX Release 11i: November 2000